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Getting Started

To get up and running quickly with Newton Connection, turn to the next page
and follow the Quick Start instructions. For more detailed installation
instructions, read “Installing Newton Connection” later in this chapter and
“Synchronizing Your Information” in Chapter 2.

In this chapter
m Quick start
m What is Newton Connection for Windows?
m In this package
m Installing Newton Connection
m Starting Newton Connection
m Highlights of the screen
m Getting help
m Quitting Newton Connection
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Quick start
This Quick Start lists the basic steps to install and start Newton Connection
on your PC, attach the Newton device and PC by cable, and transfer
information between the two machines.
To install Newton Connection on your PC:
1

Place the Install disk in the appropriate floppy drive.

2

If necessary, type WIN [Enter] to start Windows.

3

In Windows Program Manager, choose Run from the File menu. Type A:\INSTALL, then
choose OK.

Or, if you are using the B drive, type B:\INSTALL.
4

Respond to the Install questions as prompted.

In order for Newton Connection to work properly on your PC, Install
automatically modifies some system files. You also have the choice to create a
new group or to place the Connection icon in an existing Program Manager
group. For more information, see “Modifying Windows System Files” in
Appendix B.
5

After the software is installed, choose to restart Windows in order for the changes to
take effect.

For more information on installing the software, see “Installing Newton
Connection” later in this chapter.
To connect Newton and your PC by cable:
1

Connect the end of the cable with 9 holes to an available serial port on your PC.

If you have a 25-pin serial port, use the enclosed adapter.
2

Connect the other end of the cable to the communication port on Newton.

For more information on connecting by cable, see “Connecting Newton to a
PC” in Chapter 2.
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To start Newton Connection and perform your first synchronization:
1

From Windows, double-click the Newton Connection icon.

Newton Connection displays instructions for synchronizing with Newton.
2

Ensure that the Connection button is pushed in to enable communications.

Refer to the illustration below to locate the Connection button.
3

On the Newton, tap Extras to open the Extras Drawer, then tap Connection.

4

Tap DOS or Windows PC in the list of options, then tap Connect.

Synchronization begins. A dialog shows the status of the synchronization.
When you synchronize for the first time, a unique workfile is created on the
PC. This file contains all the data from your Newton. For more information
on synchronizing with Newton, see “Synchronizing Your Newton With the
PC” in Chapter 2.
The Connection button indicates
that the software is ready to
receive information from Newton.

The name of your workfile is
displayed here after you
synchronize for the first time.
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What is Newton Connection for Windows?
Welcome to Newton Connection for Windows, the Newton communications
utility for your PC. Newton Connection is an application that allows you to
store, view, and edit Newton information on your PC. You can synchronize
while the Newton Connection software is minimized or fully displayed—it’s
up to you.
Newton Connection lets you update and store your Newton information.
When linked by cable, your PC and your Newton can communicate so that
both contain the same information. Newton Connection also takes care of
backing up workfiles and archiving items you deleted from Newton.
Newton Connection provides the following features:
m automated synchronization of your workfile and Newton data
m multiple file editing
m an easy-to-use graphical interface
m automatic data archiving
m search capabilities
m ability to exchange information with other Windows applications
m sorting based on fields in the summary view

4
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In this package
Check the contents of your Newton Connection package:
m the Newton Connection program disks
m Newton Connection Kit for Windows User’s Guide
m Newton Connection cable
m 9-pin to 25-pin adapter
m registration card

Installing Newton Connection
The Newton Connection installation program, INSTALL.EXE, performs
several tasks: it creates a directory for the Newton Connection files;
decompresses and copies the files to your hard drive; modifies the
SYSTEM.INI and WIN.INI files; and optionally modifies the
PROGMAN.INI file. For more information about how these files are
modified, see “Modifying Windows System Files” in Appendix B.
Before you begin to install the Newton Connection software, you should
verify that your system meets the necessary minimum requirements. For a list
of system requirements, see “System Requirements” in Appendix B.
For the easiest operation, a mouse or other pointing device is recommended.
For information about using the keyboard with Newton Connection, see
“Moving Around in Newton Connection ” in Appendix A.

Getting Started
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To install the Newton Connection software:
1

Place the Install disk in the appropriate floppy drive.

2

In Program Manager, choose Run from the File menu.

To run Install, choose
Run from the File menu
in Program Manager.

3

Type A:\INSTALL and choose OK.

If you are using the B drive, type B:\INSTALL instead.
When you’re ready to
begin, click OK.
Type the drive
and command
here to run the
Install program.

4

Click here to move to
the floppy drive and
select INSTALL.EXE.

Follow the on-screen instructions.

Newton Connection is installed in the Newton directory. At the end of the
installation process, you’ll be asked to restart Windows. It’s important that you
restart Windows so that communications can work properly. After restarting
Windows, the Connection icon appears in the Newton group or the group you
specified during installation.
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Starting Newton Connection
You can start Newton Connection in a couple of different ways: from the
Program Manager, double-click the icon; from the File Manager, double-click
a workfile; or drag your .NWT workfile over the program icon.
The first time you start Newton Connection, there is no workfile for you to
open. You must synchronize with your Newton in order to create a workfile
on your hard drive. The identification code in this file corresponds to your
particular Newton, ensuring that you don’t synchronize with the wrong file.
For more information about workfiles, see “Managing Your Information” and
“Creating and Opening Workfiles” in Chapter 2.
To start Newton Connection:
m In Program Manager, double-click the Newton Connection icon. Or in File Manager,
double-click the workfile you want to open.

Double-click the icon
to start the program.

The Install
program creates
a new group for
the Connection
software.

Newton Connection displays instructions explaining how to synchronize your
Newton with the PC. You need to synchronize in order to create your first
workfile. For more information, see “The First Time You Synchronize” in
Chapter 2.

Getting Started
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Highlights of the screen
The Newton Connection application window contains three major areas: the
main workspace which displays your data in windows; the menu bar,
containing menus and commands; and the toolbar, containing buttons to
quickly access the most common actions. Additionally, a status bar at the
bottom of the main workspace displays help messages according to where you
are in the main interface and what you are currently doing.

The main workspace
Whenever you open a workfile, the Newton information is displayed in the
main workspace. The workspace contains windows, each one representing a
separate workfile. Each window can show one category (for example, the
Notepad) at a time. Known as the summary view, this window contains all the
items of the current category. For example, when you choose Notepad, the
window displays the first few words of the note.
These buttons allow you to
quickly change categories.

The main window
contains a summary
of items from the
current category.

The status bar gives you hints about
where you are in the program.
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In Notepad, the first line of your text
displays in summary view. You also see
how many shapes are in each note.

The menu bar
The menu bar at the top of the main window contains standard Windows
menus. Newton Connection commands appear on these menus. You can
activate the menu bar with the mouse or with the keyboard. For more
information about using menus, see “Using Menus, Commands, and Dialogs”
in Appendix A.

The current category
has a checkmark
next to its name.

A command with an ellipsis
displays a dialog box.

The toolbar
The toolbar is situated below the menu bar and just above the main window.
Buttons on the toolbar provide immediate access to the most common Newton
Connection commands and functions.
The standard category
buttons are Notepad, Name
File, Calendar, and To Do.

The Zoom and New Item
buttons display the close-up
view for a category.

The editing buttons
are Cut, Copy,
Paste, and Undo.

The Connection button
turns the polling of
serial ports on and off.

The Search button
displays a dialog for
entering search criteria.

The Dates Navigator
is for use with the
Calendar and To Do.
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Getting help
Windows Help for Newton Connection is available at any time by pressing F1.
Also, as you work with Newton Connection, a status bar at the bottom of the
main window shows a brief text message describing the button, command, or
item you are currently using.
The Help menu allows
you to choose the type
of help you want.

The status bar displays a brief
message designed to help you
with the command or item.
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Quitting Newton Connection
When you exit, Newton Connection closes any opened files. Newton
Connection saves your information automatically as you enter it, so you don’t
have to worry about saving the workfile before you exit. For more
information about the way Newton Connection saves information in your
workfile, see “Saving Your Information” in Chapter 2.
To quit Newton Connection:
m Choose Exit from the File menu.
Double-click the
control box to close
just this workfile.

The Exit command closes
all open workfiles before
exiting the program.

Getting Started
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Managing Your Newton Information

With Newton Connection, you can synchronize your Newton with your PC.
You can also perform other file and information management tasks.

In this chapter
m Managing your information—overview
m Connecting your Newton to a PC
m Synchronizing your Newton with the PC
m Creating and opening workfiles
m Saving your information
m Backing up workfiles
m Tips for managing information
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Managing your information—overview
Your information and ideas on Newton are valuable. One of the best ways to
protect them is to put a copy in a safe place, such as on your PC’s hard drive.
Newton Connection can automatically create a workfile which contains a
copy of your information and provides a safety net in case of loss.
When you transfer Newton’s information to your PC’s hard drive, it is stored
in a workfile. Each Newton device has one workfile associated with it. Every
time you synchronize, a backup file is created and deleted items are moved to
the archive file. For more information about archive files, see “Archiving
Items” in Chapter 4.
Once you have the information on your PC, you can use Newton Connection
to view, edit, or print it. The PC’s larger display and keyboard make it easy for
you to revise outdated information. You can easily and efficiently add new
items to your Newton information as well.
When you synchronize,
Newton’s information is
transfered to your PC
and stored in a workfile.

Workfile

A backup copy of the workfile is
created each time you synchronize.
Retrieve your information by choosing
the Restore command with a backup
file.

When you delete an item,
it is sent to the archive file.
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Connecting the Newton to a PC
Before you can transfer information between the PC and Newton, you need to
connect the two machines with a serial cable. Newton Connection
communicates with Newton through a serial port on your PC.
PC serial ports come in two sizes—9-pin or 25-pin. On some computers a
serial port may be labeled COM1, COM2, COM3, COM4, or SERIAL. When
your Newton device is connected, you don’t need to know which port it’s
on—the Connection software finds it automatically. For more information on
customizing serial port settings and using other communications applications
at the same time as Newton Connection, see “Changing the Port Setup” in
Chapter 4.

The Newton Connection
cable is designed for use
with a 9-pin serial port.

If your computer has a 25-pin
serial port you can use the
included adapter to connect.

Attaching the cable
In your Newton Connection package, you received a cable with a 9-pin serial
connector at one end and a Newton connector at the other. Use this cable to
connect your PC and Newton.
IMPORTANT Use only the Newton Connection cable. It’s specifically designed

for communication with Newton. Other types of cables may not work.
To connect your Newton and PC by cable:
1

Choose an available serial port on your PC.

2

Connect the end of the cable with 9 holes to the appropriate port.

If you have a 25-pin serial port, use the enclosed adapter. Push the smaller
end of the DB9-DB25 adapter onto the 9-hole end of the cable. Then plug the
larger end of the adapter into a matching 25-pin serial port.

Managing Your Newton Information
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3

Plug the other end of the cable into the Newton’s communication port.
Serial ports
Newton’s
communication port

Serial cable

Synchronizing your Newton with the PC
Periodically, you will want to save a copy of your most current Newton
information on your PC. Maybe you’ve updated items or added a lot of new
information to the workfile and need to transfer it to Newton. The process of
copying information between your Newton and your PC is known as
synchronizing. The synchronization process ensures that the items in your
Newton exactly match the items in your workfile.

The first time you synchronize
When you first start the Newton Connection application, instructions are
displayed on how to synchronize.
The first time you synchronize, Newton Connection creates a workfile on
your hard drive in the Newton directory. This file then receives all of the
information contained on the Newton device. You can then use Newton
Connection to add information to the workfile. The next time you
synchronize, the new information is added to Newton.
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The archive file is also created the first time you synchronize. It contains
items you’ve deleted from Newton. If you delete the archive file, a new, empty
file is created the next time you synchronize.

The green arrow
indicates that Newton
Connection is ready
to synchronize.
These instructions
explain how to start
synchronizing.

IMPORTANT If you are having problems making a connection, verify that the
port you are using is enabled for communications with the Newton. For more
information about port configuration, see “Changing the Port Setup” in
Chapter 4. For information about resolving port contentions in Windows, see
“Troubleshooting” in Chapter 4.

Synchronizing your information
Depending on how much new information you have to transfer, you may want
to synchronize once a day, or you may need to synchronize only once a
week—it’s up to you.
IMPORTANT It’s recommended that you use Newton’s power adapter when

synchronizing. The synchronization process may take some time depending
on how much information has changed.

Managing Your Newton Information
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To synchronize your PC with Newton:
1

Make sure your Newton and your PC are connected with the serial cable.

For more information, see “Attaching the Cable” above.
2

On Newton, tap Extras ´ to open the Extras Drawer, then tap Connection.

Tap Connection to choose
a connection.

3

Tap DOS or Windows PC.

Tap here to tell Newton
you’re connected to a PC.

4

To begin synchronizing, tap Connect.
The Connect button tells Newton to
start communicating with the PC.
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A message on your PC shows the progress. Cancel to stop synchronizing.

The name in the
Personal Preferences
area of your Newton
is displayed here.
If you wish to cancel
synchronizing, click here.

If you choose to stop synchronizing, Newton Connection returns the workfile
to its previous state. That is, the workfile is exactly the same as if you had
never started synchronizing.

Confirm that you want to cancel
synchronizing by clicking here.

Creating and opening workfiles
You can create new workfiles for additional sets of information. For example,
you may want to create a workfile to contain just your new business contacts.
These extra files cannot be directly synchronized with your Newton device,
but you can move items from these workfiles into your main workfile. The
new items are then copied to Newton the next time you synchronize.

Creating workfiles
While working in Newton Connection, you must have an existing workfile
open before you can create a new one. Use the New command on the File
menu to create a blank workfile. If there is more than one file open, the
currently active file is used as a template for the new file.

Managing Your Newton Information
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To create a new workfile:
1

Choose New from the File menu.

Newton Connection displays the New File dialog box.
2

Specify a name for the file in the File Name field.

3

Choose OK.

Newton Connection creates a new workfile and displays it in summary view.
Use the Directories list box
to change where your
work files are stored.

Type a name for
the new workfile.

Click here to create
the new workfile.

Click here to close the dialog
without creating a new workfile.

Use the Drives list box to
switch to a different drive.

Opening workfiles
Before you can view, edit, or add items in Newton Connection, you must open
a workfile. You can then view your information and add, edit, or print items.
To open a workfile:
1

Choose Open from the File menu.

2

Use the Drives and Directories lists to move to the drive and directory for your workfiles.

You can also type a path in the File Name field. For example, type
C:\NEWTON\*.NWT to display the Newton Connection files.
3

In the Files list, choose a workfile to open.

If you know the name of the file, type it directly into the File Name field.
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4

Choose OK.

Newton Connection displays the workfile in a window.

You can switch
between windows
by choosing a
filename from the
Window menu,
pressing Ctrl+Tab,
or clicking the
window you want
to work in.

The active file has
a checkmark next
to its name.

You can open two files at the same
time and use the clipboard to exchange
information between them.

When you start Newton Connection, any files that were open during your last
session are automatically reopened for you.

Saving your information
As you work in Newton Connection, your changes and additions are
automatically saved in the workfile. You do not need to choose a command or
specifically request that the new information be saved. Each time you edit an
item, it is saved in the workfile.
If you want to create a new, empty workfile containing your current Newton
categories, use the New command.

Managing Your Newton Information

21

To save part of your data in a new file:
1

Choose New from the File menu to create a new workfile.

For more information, see “Creating Workfiles” earlier in this chapter.
2

To display the workfiles side by side, choose Tile from the Window menu.

3

From your main workfile, select the items from categories you want to save in the new
file.

4

Choose Copy from the Edit menu.

5

Move to the file created in step 1 by clicking it to make it active.

6

Choose Paste from the Edit menu.

Repeat steps 3 through 6 for each category of information you want to include
in the new file. These items are automatically saved in the new file as you
paste them.

Select records from this
file, then choose Copy
from the Edit menu.
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Activate this file by
clicking the title bar,
then choose Paste
from the Edit menu.

Backing up workfiles
Backup files are created automatically whenever you synchronize with your
Newton. During synchronization, Newton Connection creates a backup file
before beginning to move information back and forth between Newton and
your PC. The backup file contains a copy of the workfile as it was before you
started synchronizing.
Each workfile has its own associated backup files with the extension .NB#,
where # is a number from 1 to 9. You can have up to 10 backup files per
workfile. The file with the extension “.NB” is always the most recent backup.
For example, the workfile MATT.NWT would have backup files called
MATT.NB, and MATT.NB1 through MATT.NB9.
Backup files contain copies of the items present just before you synchronized.
For more information about preserving deleted items that were previously
synchronized, see “Archiving Items” in Chapter 4. For information about
restoring from a backup file, see “Restoring Information to Newton” in
Chapter 4.
To specify how many backup files are created:
1

Choose Preferences from the Newton menu.

The Preferences dialog is displayed.
2

In the Backup files option, choose a number between 1 and 10.
Click here to save
your preferences.

Enter the number of
backup files to create.

3

Choose OK.
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Tips for managing information
Sharing information with multiple workfiles
You can create extra workfiles on your PC that contain various sets of
information. With these auxiliary PC workfiles, you can add or remove
information from your main workfile so that your Newton’s memory doesn’t
become too cluttered.
For example, say you are traveling to a business meeting in Hershey, PA, and
need to bring the latest statistics on candy bar consumption. While these
statistics are important, you don’t need to have them with you every day for
business. Keep a permanent copy of the candy bar statistics in a PC file
named CANDY.NWT. Then just copy them into your main workfile on the
PC as needed and synchronize to copy them to your Newton. After the
business trip is over, delete them from Newton and from the main workfile,
then synchronize again.
You can also use multiple workfiles to distribute updates or new information.
For example, suppose you have a mobile sales staff that needs to receive
updates of inventory and client lists. Simply create a workfile listing the new
inventory and their part numbers, as well as new client information. Send
each of your team members a copy of this file via modem. Your sales people
in the field can then update their individual workfiles by copying the new
information into their main workfile and then synchronizing with Newton.

Office PC
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Send the file by
modem from
your office PC.

Place the
information in the
main workfile.

Synchronize
with Newton.

Modem

Laptop

Newton

Seamless synchronizing in Windows
To synchronize in the background after starting Windows, start Newton
Connection and iconize it. You can then just plug the cable into the Newton’s
port and, on the Newton, choose Connect from the Connection options in the
Extras Drawer. Switch to other applications on the PC to continue working on
other tasks. Newton Connection will continue to synchronize while you work
on other tasks.

Leave Connection running as an icon on the
desktop. Then you can synchronize in the
background while you work on other tasks.

Managing Your Newton Information
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3

Viewing, Editing, and Printing Information

Once you’ve synchronized your Newton device and PC, you can use Newton
Connection to view, edit, and print your information.

In this chapter
m What are categories?
m Viewing an item
m Adding and editing information
m Controlling the way information is displayed
m Printing your information
m Tips for working with information
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What are categories?
Newton Connection stores your information as separate items. Each item
belongs in one of several categories that correspond to areas on Newton. Each
of the Newton Connection categories is designed to organize and display
information in a way that makes it easy to access and understand. There are
four predefined categories—Notepad, Name File, Calendar, and To Do. Each
category is described in greater detail below.
The pre-defined categories are represented by buttons on the toolbar and
match commands on the View menu. Click one of these toolbar buttons to
quickly display a category.
Additionally, you can purchase packages that expand the functionality of your
Newton by adding new categories or other features. For more information on
installing packages, see “Installing Packages” in Chapter 4.

Notepad
Notepad offers an easy way to view memos, ideas, and original compositions
created on your Newton. Notepad is the most free-form of the categories,
allowing you to view and edit text-based information. You can also see your
graphics and can copy them to other programs.
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Name File
Name File is like a set of index or rolodex cards. It contains fields for name,
company, address, multiple phone numbers, and birthday.

Calendar
Calendar contains a summary of your appointments sorted by date and time.
Each item scheduled in the Calendar consists of a date, time, title, and
description of the planned activity. You also see the day notes for that day.

To Do
To Do provides a quick way to list tasks and other items that you need to
complete. A summary of To Do items shows the first line of each task’s
description. You can also assign a priority level to your tasks.
Notepad
The View menu
contains commands
for each category.
The current category
has a check mark.

Calendar
Clicking a button on the toolbar
is the same as choosing a
command from the View menu.

Name File

To Do

Viewing, Editing, and Printing Information
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Viewing an item
Items are stored in categories according to the type of information they
contain. For example, to view an appointment, you display the Calendar
category.
You can view a category in one of two ways in Newton Connection. The
summary view displays a brief description of each item, one item per row.
The close-up view is used to view and edit a single item.

Summary view
Summary views offer a quick list of all items in the current category. Each
item is listed on a separate line containing one or more fields. For example,
you can identify individual appointments in the calendar based on the first
few words of the description field.
You can change which fields are displayed in summary view. For more
information, see “Changing the Fields Displayed in Summary View” later
in this chapter.
Click here to return
to the current date.

The Calendar’s
summary view lists
your appointments by
date and time.

Use the Dates
Navigator to
move ahead to
the next day or
month.

Click the date to
add a new item
for that day.

A day note is like an appointment,
but has no time associated with it.
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Close-up view
Close-up view displays the entire contents of one item for you to view or edit.
Select an item from the summary view and choose Zoom either from the
toolbar or from the View menu. Newton Connection displays the information
in a separate window where you can edit it.
These buttons allow you
to move between items
or create a new one.

The close-up view
contains various
fields, depending on
the category. This is
the close-up view for
Notepad.

Dismiss the close-up
window by choosing Close.

Using the Dates Navigator
Display the Dates Navigator to move to another day or month in the Calendar
or To Do category. Choose the day of the month by clicking the date. The
view moves to that day’s appointments or to-do list.
Click here to move to
the previous month.

Click here to move
to the next month.
Click a date to bring
that day's items to
the top of the list.
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Adding and editing information
You add and edit items using close-up view. When you choose to add a new
item to a category, Newton Connection displays the close-up window for that
category. You can type your information directly into the fields.
To add a new item:
m Choose New Item from the Edit menu or toolbar. (Or choose the New Item
button in the close-up window.)
The close-up window is displayed. After you add information into the various
fields, you can move to another item or close the window. Your changes are
then automatically saved in the workfile.
To edit an existing item:
1

In the summary view, select the item you want to edit.

2

Do one of the following:

m Double-click the item.
m Highlight the item and press Enter.
m Highlight the item and choose Zoom from the View menu or toolbar.
The close-up view of the item is displayed.
3

Type new
information or
edit your existing
text in any of the
fields. Use the
Tab key to move
to the next field.

Add to or edit the existing information.
Click here to move forward or
backward one item at a time.
Click here to add a new item.
Dismiss the window by
choosing Close.

IMPORTANT You cannot edit or delete repeating appointments in the Calendar

using Newton Connection. Also, you can’t edit graphics included in a note.
For more information, see “Working with Notes” below.
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Working with notes
There are two types of notes you can work with—notes from the Notepad
category and notes from the Calendar and To Do categories. Name File has
notes you can view: you can’t edit Name File notes on the PC.
When working with the notes, you can view both text and graphics. However,
you can’t edit the graphics. On the PC, notes for appointments or to-do items
only display text. If you have a graphic image in Newton’s Calendar or To Do
List, you can move it to the Notepad before synchronizing with the PC. You
will then be able to view that graphic on your PC.
To work with your graphics on the PC, cut or copy an entire note, then paste
it into another Windows program, such as Paintbrush. For example, you may
have created a preliminary drawings for a new widget. You can copy that note
to the clipboard, then paste it into Paintbrush to refine or edit the drawing.
However, you can’t paste graphics from another application back into the
Notepad.
To edit a note:
1

From the summary view, select the note you want to edit.

2

Do one of the following:

m Double-click the note.
m Highlight the note and press Enter.
m Highlight the note and choose Zoom from the View menu or toolbar.
The close-up view of the note is displayed.
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3

Edit and reformat the text as follows:
Use these controls to
format the selected text.
Click here to move
forward or backward
one item at a time.
Dismiss the window by
choosing Close.

Click here to edit the next
or previous text group.

4

Click here to add a
new text group.

Choose New Item to add another note, or choose Close to return to the summary view.

Your changes are automatically saved in the workfile when you move to the
next item, close the window, or create a new item.

Moving information
In Windows, the clipboard acts as a common location for moving text and
other information.
Use Cut and Copy to place selected items on the clipboard. Use Paste to
insert the text or item at another location. The contents of the clipboard
remain the same until you choose the Cut or Copy command again.
IMPORTANT If the contents of the clipboard are not in a usable format, the

Paste command on the Edit menu is dimmed or grayed out. For example,
graphics from a drawing or paint program cannot be pasted into a Notepad
item. Items from one category can’t be pasted into another category. Also,
when you look at an item on the clipboard in Windows, it does not look the
same as it would look in Newton Connection.
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To move information:
1

Select the item or text you want to move.

To select more than one item in a row, hold down the Shift key and click the
items with the mouse. To select random items, hold down the Ctrl key
instead.
2

Choose Cut from the Edit menu.

The selection is placed on the clipboard
3

Display the category, item, or other location you want to move the selection to.

4

Click once to place the cursor if you want text to be inserted into a specific field.

5

Choose Paste from the Edit menu.

The text is inserted.
If you’re inserting an entire item, such as a note or to-do item, it appears
at the end of the summary view list. If you are moving an appointment, it
appears on the new date in the Calendar. Name File items appear according
to their sort order.

Select items
from this file,
then choose
Copy from the
Edit menu.

Activate this
window by
clicking the
title bar, then
choose
Paste from
the Edit
menu.
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Removing information
There are two ways to remove information from a category or item in
Newton Connection. The Cut command removes the selection—text or an
entire item—and places it on the clipboard. The Delete command removes
the selection without placing it on the clipboard. The only way to reverse the
effects of the Delete command is to use Undo immediately after choosing
Delete. In any situation where you want to be able to recover deleted text, it’s
best to use Cut instead of Delete.
IMPORTANT When you delete an entire item from Newton, it is sent to the

archive file when you next synchronize. For information, see “Retrieving
Information from the Archive File” in Chapter 4.
To remove selected items from the workfile:
m Choose Cut from the Edit menu to place the selection on the clipboard.
m Or, choose Delete from the Edit menu to remove the selection without
placing it on the clipboard.

Reversing editing changes
If you decide that you don’t want your last editing change, use Undo on the
Edit menu. Undo reverses the Cut, Copy, Paste, Delete, and Undo commands.
To reverse the last editing action:
m Choose Undo from the Edit menu.
IMPORTANT Undo reverses only the last editing action.

If you change an item in close-up view and then want to restore the original
version, you can restore the old item from a backup file or the archive file.
For information about restoring items, see “Retrieving Information from the
Archive File” in Chapter 4.
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Controlling the way information is displayed
If you have a large workfile, you may find it convenient to view subsets
of available items. Searching allows you to view only those items that match a
set of criteria. You control the way information is displayed in the summary
view. You can change the way items are sorted. You can also select which
fields you want to display in the summary view and control their order.

Searching for information
Searching is based on text within text fields, options, folders, and dates,
depending on the current category. You can have a different set of search
criteria for each category of information.
To start a search, you specify some text or other requirements in the Search
dialog. After searching, you see only those items that meet your criteria. The
Search dialog looks like the close-up view for the current category.
To search for items:
1

Choose Search from the View menu.

The Search dialog is displayed.

In this example, all of the
notes in the Personal
folder with information
about “Sharon in
Bellevue” are displayed
when you click OK.

Add text to a field
to indicate what to
search for.

2

Enter text in the fields you want to use as search criteria, or select options.

3

Choose OK to start the search.
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Turning off a search
As long as a search is active, you won’t have access to your complete set of
information. You can cancel an active search by clicking the Search button on
the toolbar or by choosing the Search command from the View menu. When a
search is no longer active, the checkmark next to the Search command is
removed.
To turn off a search:
m Choose Search from the View menu or toolbar.

The checkmark no longer appears next to the Search command and the
Search button no longer looks pressed down. You now see your complete set
of information for that category.

Sorting your items in the summary view
You can customize the way the summary view displays information by
choosing a different sort order. Sorting works only on the currently displayed
items: if there is a search in effect, you will see a sorted list of just those
items.
Sorting works by choosing one of the fields as the sort criterion. You can
display your items in an ascending or descending order.
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To sort items:
m Click a button on the sort bar that corresponds to the field you want to sort by.

You can sort on any field displayed in the summary view of most categories.
However, Calendar and To Do items are always sorted by date.

This button indicates
that the sort order is
Descending. Click it to
change to Ascending order.

The sort bar allows
you to control the
order items are
displayed in.

The Ascending/
Descending
button changes
depending on
the sort order.

The view menu also contains commands that allow you to change the sort
order. The Sort By list corresponds to the fields displayed in summary view
and on the sort bar.

The sort order is
either Ascending
or Descending.

The fields listed here
correspond to the
summary view of the
current category.
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Changing the fields displayed in summary view
You control which fields are displayed in the summary view of a category
with the Field Display command on the View menu. The order in which the
fields are listed depends on the order you chose them in. You can move fields
around to change their display order as well.
To change the summary view display:
1

Choose Field Display from the View menu.
Click here to remove
any selected fields from
the Field Order list.

Click OK to close
the dialog and change
the summary view.
Choose among the
available fields from
this list. Double-click to
quickly move items into
the Field Order list.
Click here to add the
fields you selected to
the Field Order list.

2
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Use these buttons
to change the order
of the fields in the
Field Order list.

Choose OK to close the dialog and display your changes in the summary view.

Printing your information
Printing in Newton Connection is controlled by Windows. You can send your
information to the Print Manager or to a network queue. With the Print Setup
command, you can select a local or network printer. You can choose what you
want to print—individual items or an entire category—from the Print dialog.

Choosing a printer
When you have more than one printer available to your PC, Windows needs
to know which one to send your information to. Normally, the default printer
is used, but you can choose any printer from the available printers.
To choose a printer:
1

Choose Print Setup from the File menu.

2

Select a printer from the list.

Choose either the default printer or select an alternate printer from the dropdown list. For more information about adding printers to your list, see the
Windows User’s Guide.

Choosing what to print
You have the option to print all items from the current category, or only those
items you’ve preselected.
To print with Newton Connection:
1

Display the category you want to print.

If you want to print only certain items, select those items now. Or limit the
display of items by searching for specific records with the Search command.
For more information, see “Searching for Information” above.
2

Choose Print from the File menu.
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3

Choose the desired print options:

m If you want to print all items, choose All. If a search is active, then only
the currently displayed items will print.
m If you want to print only the selected items, choose Selection.
m If you want to print Calendar or To Do information belonging to specific
days, choose the Dates option and enter the beginning and ending dates.

Click here to change
your printer setup.

Click an option to
specify how many
pages are printed.

4

Click OK.

Tips for working with information
Creating customized mailing lists
Use the Folders field in conjunction with Search to create specialized mailing
lists from your Name File information. For example, if you want to create a
list containing all the people you want to send holiday cards to, name one of
the folders “Holiday” on Newton. Then when you synchronize the
information to the PC, you can search using the Folder field in Name File.
You can then print a Name File list that contains only those people you want
to send a card to.

Creating an itinerary for business trips
You can use the Calendar summary view to print an itinerary for business
trips or other travel plans. Simply choose the starting date using the Dates
Navigator, then select only those items pertaining to your trip. Choose Print
from the File menu and fill in the dates of your trip. Choose OK to print a
summary of your schedule. Use this printout to notify your traveling
companions or your administrative assistant of your plans.
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Customizing the Way
You Use Newton Connection

In this chapter, you learn how to modify the default settings and preferences
for Newton Connection. Restoring, archiving, and recovering items are
discussed. There are instructions for adding new functionality to the Newton
by installing software packages. The last section contains suggestions on how
to handle common communications difficulties.

In this chapter
m Customizing Newton Connection
m Restoring information to Newton
m Archiving items
m Retrieving information from the archive file
m Installing packages
m Troubleshooting
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Customizing Newton Connection
In Newton Connection, the way your PC manages your Newton information
can be modified by changing the user preferences. You can also modify
settings for the serial port through which the Newton Connection application
and the Newton device communicate.

Setting user preferences
You can specify a directory to store your workfiles, how many backup files
are created, how much memory to use, and whether to show the toolbar. Your
preferences are stored in the NEWTON.CFG file. If this file is deleted, the
default preferences are restored.
To change the default preferences:
1

Choose Preferences from the Newton menu.

2

Choose or modify your options as follows:
Type the path of the
directory where you
store your workfiles.

Click Browse to move
through the directories
on your hard drive.
Click here to accept the new
settings and close the dialog.

Enter a number from
1 to 10 to specify how
many backup files are
kept.

Click here to display the Port
Setup dialog, where you can
enable and disable serial ports.

Click here if you want
your workfile opened
after synchronizing.
Click here if you need
to use more memory
for large files.

3

A checkmark here indicates
that the toolbar is displayed.

Choose OK to accept the new preferences.

Choose Cancel if you want to keep the old preferences.
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Changing the port setup
Newton Connection communicates with Newton through a serial port. If you
have a non-standard port, you may need to modify the settings before Newton
Connection can transfer your data to the PC. Or, if you are using another
communications device at the same time as Newton Connection, you need to
make sure the two aren’t trying to use the same serial port.
IMPORTANT Newton Connection is designed to operate automatically with

most PCs. You shouldn’t have to change the port configuration unless you
have a non-standard serial port. If you must change the port setup, check the
hardware manufacturer’s documentation to determine the proper settings.
To configure a serial port:
1

Choose Preferences from the Newton menu.

2

Choose Port Setup from the Preferences dialog.

The Port Setup dialog is displayed.
Check Enabled to allow Newton
Connection to use a particular port.

Enter a new value for
the address here.
Click this button to set the ports
back to their original values.
Type a new value for
the baud rate here.
Click the arrow to display a
list of available baud rates.

3

Enter new values for the address and baud rate.

If you are not sure of the proper baud rate, choose a lower setting. For
example, when you have trouble synchronizing with a non-standard port,
lower the rate to the next lowest setting.
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4

Check Enabled to allow Newton Connection to use a particular port.

If you want Newton Connection to skip a specific port, make sure that the
Enabled option for that port remains unchecked. For example, if your modem
is attached to COM2, disable communications for that port by clicking to
remove the checkmark.
5

Choose OK to update your port configuration and close the dialog.

For troubleshooting information related to serial ports, see “Advanced Port
Setup Problems” later in this chapter.

Controlling automatic communications
Newton Connection is set to actively listen on all enabled serial ports
for a Newton attempting to synchronize. You can disable automatic
communications for a specific port, allowing other communications products
to use that serial port. Or you can turn off listening altogether, to allow other
Windows programs to have control of all your serial ports.
To disable communications for a specific serial port:
1

Choose Preferences from the Newton menu.

2

Choose Port Setup from the Preferences dialog.

3

Choose the Enabled option next to a port to remove the checkmark.

To re-enable communications for synchronizing through that port, click the
Enabled option so that it is checked.
4

Choose OK twice to close the Port Setup and Preferences dialogs.

You can temporarily turn off Newton Connection’s polling of your serial ports
with the Communications On command or the Connection button on the
toolbar.
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To turn off communications for all serial ports:
m Choose Communications On from the Newton menu to remove the
checkmark.
m Or, click the Connection button on the toolbar.
A warning message is displayed informing you that you can’t synchronize
with the Newton until you turn communications back on. Click the
Connection button a second time to turn communications back on.
This message informs you that you
have turned off the ability to
communicate with the Newton.

Click here if you
don’t want to see
this message
when you disable
communications.

Click here to dismiss the message.

Restoring information to Newton
If you lose information on your Newton or your information becomes
damaged, you can use the backup file to restore the items from the last time
you synchronized. The Restore command on the Newton menu allows you to
put information back into Newton whenever you need to recover lost
information. You can restore from any backup file or workfile.
To restore an entire workfile to the Newton:
1

Connect your Newton and your PC with the Newton Connection cable.
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2

Choose Restore from the Newton menu.

The Restore dialog box is displayed.
Use the Directories list box to locate
where your backup files are stored.
Click here to start restoring
from the backup file.

Type the name of the
backup file, or choose
one from the list.

Click here to dismiss the
dialog without restoring.

Use the Drives list box to
switch to a different drive.

3

Choose the backup or workfile you want to restore data from.

4

Choose OK.
WARNING When you restore from a backup file or workfile to Newton,

you lose all the information you have entered after the date of the
backup file you’re restoring from.
5

On Newton, open the Extras Drawer and tap Connection.

6

Tap DOS or Windows PC, then tap Connect.

Newton Connection deletes all information from Newton. Then all items
from the selected backup or workfile are transferred to Newton.
IMPORTANT Restoring from the archive file is not recommended. The contents
of the archive file may not fit in Newton’s memory. For information about
recovering items from the archive file, see “Retrieving Information from the
Archive File” later in this chapter.
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Archiving items
To avoid clutter on the Newton, it’s a good idea to periodically remove older
items from your Newton or workfile. Whenever you delete an item from
Newton and then synchronize, Newton Connection moves it to the archive
file, ensuring that a complete history of your Newton information is retained.
IMPORTANT When deleting items from the Newton, you must have previously

synchronized that item with Newton Connection in order for it to be moved
to the archive file. If you create an item and then delete it before having
synchronized, then it is not transferred to the archive file.
The number of items in an archive file is limited by the amount of available
memory and the free space on your hard drive. Each workfile has its own
associated archive file with the extension .NAR. For example, the workfile
BOB.NWT has an archive file called BOB.NAR.
Your archive file differs from backup files: the archive file contains all items
ever deleted from the Newton. In contrast, the backup file contains a copy of
whatever was in the workfile just before you last synchronized.
You can easily recover deleted items from the archive file. For information,
see “Retrieving Information from the Archive File” below.
IMPORTANT You can open and edit the archive file as with any other workfile.

However, if you delete items from the archive file, you can’t recover them.
To archive old items:
1

Be sure that the items you want to archive are synchronized with the Newton.

2

From the Newton, select the item(s) you want to archive.

3

Delete them from the Newton.

The item is removed from your Newton. The next time you synchronize, that
item is placed in the archive file and also removed from the workfile.
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Automatically archiving old appointments
You can control the archiving of appointments with the Action button. The
Delete command allows you to specify how long to keep old appointments in
the Calendar. After the specified amount of time, old items are deleted from
the Calendar. When you next synchronize, those items are moved to the
archive file on your PC.

Retrieving information from the archive file
You can recover deleted items from the archive file. To recover an item, you
move it via the clipboard to your main workfile.
To recover items:
1

Open both the workfile and archive file.

Newton Connection displays the files, each in its own window.
2

From the archive file, select one or more items to recover.

3

Choose Cut from the Edit menu.

Newton Connection places the selected items on the clipboard.
4

Switch to the workfile’s window by clicking it.

Pressing Ctrl+Tab also moves to the next open window.
5

Display the category the item belongs in.

6

Choose Paste from the Edit menu.

The items are copied from the clipboard into your workfile.
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7

Repeat steps 2 through 6 for as many items or categories as you wish.

8

Choose Close from the File menu to close the archive file.

Installing packages
You can add new functionality to your Newton by purchasing additional
Newton software. You can use Newton Connection’s Install Package command
to transfer software from your PC to Newton.
To install a software package:
1

Make sure the Newton is connected by cable to your PC.

2

Choose Install Package from the Newton menu.

The Install Package dialog is displayed.
Use the Directories list box to locate
where the package is stored.

Click here to start
installing the package.

Type the name of the
package, or choose
one from the list.

Click here to dismiss the
dialog without installing.

Use the Drives list to
switch to a floppy drive.

3

Choose the package you want to install from the Files list, then choose OK.

4

On the Newton, open the Extras Drawer, then tap Connection.

5

Tap DOS or Windows PC, then tap Connect.

A dialog shows the status of the transfer.
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Viewing extra categories created by packages
If you have installed a package on your Newton with the Install Package
command, you may be able to view and edit the information on your desktop
computer. Some packages do not include editable data to display on your
computer.
IMPORTANT After installing the package, you must synchronize the Newton

with your workfile in order to see that information on your computer.
To view information from a package:
1

Choose Extras from the View menu.

A list of available categories is displayed to the right of the Extras command.
These categories correspond to applications in the Extras drawer on the
Newton.

The checkmark
indicates that this is
the current category.
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2

Choose a category from the available list.

The summary view for that category is displayed.
In this example, the
information from a
checkbook application
is displayed.

The check entries
are sorted by the
Check No. field.

You can now view and edit your information as with standard categories. For
more information about adding and editing items, see “Adding and Editing
Information” in Chapter 3.
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Troubleshooting
If you are having problems making a connection and synchronizing with your
Newton, you can usually fix the problem by checking one of the following:
m Make sure you are using the cable supplied with your Newton Connection
software. Other serial cables may not work.
m Check to see that the cable is firmly attached to your PC and Newton. Use
the thumb screws to tighten the connection on your serial port.
m Make sure the port you are using for the cable is enabled. To do so, choose
Preferences from the Newton menu in Newton Connection, then choose
Port Setup. The Enabled option to the right of the port should be checked.
If it isn’t, click the checkbox once to enable the port.
m Make sure that the Connection button is “on.” The button on the toolbar
should look pressed down. The green arrow indicates that communications
are active.
If you are still having difficulty, read the following list of common problems
and solutions.
You are using a modem attached to a serial port. It works fine in other situations, but not
while Newton Connection is running.

If your modem doesn’t work normally while you’re using Newton Connection,
the application may be trying to use that port instead of giving control of it to
the modem. You need to tell Newton Connection not to poll that serial port.
To disable the serial port:
1

Choose Preferences from the Newton menu.

2

Choose Port Setup from the Preferences dialog.

3

Click the Enabled option next to the port to which your modem is attached.

The checkmark next to the port name should now be gone.
4

Choose OK twice to close the Port Setup and Preferences dialogs.

Your modem should now function normally. You may need to reset the
modem.
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You see “Port Contention” warnings on COMx from Windows.

If you are running any other program that uses a serial port to communicate,
that program may be trying to use the same port as Newton Connection.
Disable that port according to the previous procedure.
You see the following error message: “Newton Connection is very low on internal
memory. Please restart the program as soon as possible or risk losing data. To prevent
this problem, set the Extra Large Memory option in Preferences.”

This message is displayed when your file has become too big to fit in the
amount of memory set aside for Newton Connection to use. To increase the
memory size available to Newton Connection, you must select the Extra Large
Memory option in Preferences, then restart the application.
When you use more memory for Newton Connection, other applications may
work more slowly.
To set aside more memory for Newton Connection:
1

Choose Preferences from the Newton menu.

The Preferences dialog is displayed.
2

Click the checkbox next to the Extra Large Memory option.

The box now has a checkmark.
3

Choose OK to close the Preferences dialog.

4

Choose Exit from the File menu.

5

Restart Newton Connection and reopen the file.

You should now be able to use the workfile without any problems. When you
are done with a large workfile, be sure to turn off the Extra Large Memory
option and restart Newton Connection.
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You begin to synchronize but the process stops before it is completed.

Your PC may be running low on memory. Try closing any Windows DOS
boxes that are running applications on the desktop and then synchronize
again. Such programs may interrupt synchronization.

Advanced port setup problems
Newton Connection uses serial ports configured according to an address and
baud rate. An address is the location within the PC’s input/output space used
by a communication device. The baud rate controls how fast communication
take place.
You can modify the address and baud rate. The following guidelines offer
suggestions on how to adjust your port’s settings:
m Address In Windows, serial port addresses usually use the following
standards: COM1=3F8, COM2=2F8, COM3=3E8, COM4=2E8. If you are
using a PS/2, usually the address for COM3 is 3220 and COM4 is 3228. But
if you have installed an expansion board for a serial port, you may have
used a different address. Check your expansion board’s documentation for
the correct address to use.
m Baud rate For most serial ports, you do not have to change this setting.
Newton Connection determines the optimal speed for communications
with Newton. A baud rate of 57,600 is the maximum speed at which
Newton can send your information to the PC. However, if you experience
problems, try a slower baud rate.
If you have installed special hardware on your PC, be sure to check the
manufacturer’s documentation for the specific settings and technical
information.
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Using Your Information with Other Programs

In this chapter
m Exchanging information
m Importing information from other programs into your workfile
m Exporting information for use with other programs
m Creating a user-defined template for information exchange
m Troubleshooting information exchange
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Exchanging information
Newton Connection provides four commands—Import, Export, Export
Selected, and Templates—for moving information to and from the Newton’s
workfile format. You can use your Newton information with other
applications by exporting it to a file that is readable by the other application.
You can use information created in other applications by using the Import
command to merge the information into your workfile.
Be sure to keep a backup copy of your original file.
IMPORTANT Exporting information is only necessary when you want to use

your Newton information with other PC applications. Importing is used to
translate information from other programs to the workfile format so that you
can view and edit it in Newton Connection.
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Importing information from other programs into your workfile
When you import information, Newton Connection translates the information
according to the selected application and then adds it to the current workfile.
IMPORTANT You can import information from any application that can read or

write to the Standard Delimited File (SDF) format. For more information
about creating custom templates for information translation, see “Creating a
User-defined Template for Information Exchange” later in this chapter.
To import information from another application:
1

Choose Import from the File menu.

The Import dialog box is displayed.
2

Select an existing file
from this list.
Select a file type
that matches the
kind of file you
want to import
information from.

Select a file to import, select a Windows application that matches the file type you want
to import, then choose OK.

Click here to display the
Templates dialog, where
you can create user-defined
translation templates.

You can also create and select a user-defined template. For more information
about templates, see “Creating a User-defined Template for Information
Exchange” later in this chapter.
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3

If necessary, select a category of information to import, then choose OK.

Click here to start
importing information.

Available categories
are listed here.

Click here to select all
available categories.
Instructions are displayed
explaining that several
categories may be imported.

Newton Connection merges the information into the selected Newton
workfile. A dialog displays the results.

Exporting information for use with other programs
When you export information to use with another application, Newton
Connection saves the information as a new file in that application’s file
format. In order to specify the new format, you can choose an applicationspecific translator or you can create a template that controls which
information is exported.
For more information about creating templates for information translation,
see “Creating a Template for Information Exchange,” later in this chapter.
To export your Newton information to another application:
1

Choose Export from the File menu.

The Export dialog box is displayed.
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2

Available categories
are listed here.

Choose one or more categories of information to export, then choose OK.

Click here to confirm
your choice.

Click here to select all
available categories.

3

Select an existing file
from this list.
Select a file type that
matches the kind of
file you want to export
information to.

Type a new file name or select an existing name in the File Name field, select an
application to export to, then choose OK.

Click here to display the
Templates dialog, where
you can create user-defined
translation templates.

Alternately, you can select a user-defined template. For more information
about templates, see “Creating a User-defined Template for Information
Exchange” later in this chapter.
IMPORTANT If you select multiple categories and then choose an application

that only supports one of those categories, your file will contain information
from only that category.
4

If you selected an existing file name, click Replace to write over the information in that
file.

Choose Cancel to go back and select a different file name if you don’t want to
write over that file. Newton Connection exports the information to the
selected file. A dialog displays the results of the export. You can now work
with your information in the other application.
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Exporting selected items
If you wish, you can export specific items from a category. You follow the
same process as for exporting all of your items, but first you select which
items to export.
To export selected items from the current category to another application:
1

From the summary view, select the items you want to export.

You can only select items from one category at a time.
2

Choose Export Selected from the File menu.

The Export Filename dialog box is displayed.
3

Select an existing file
from this list.
Select a file type that
matches the kind of
file you want to export
information to.

4

Select an existing file name or type a new name in the File Name field, choose an
application to export to, then choose OK.

Click here to display the
Templates dialog, where
you can create user-defined
translation templates.

If you selected an existing file name, choose Replace to write over the information in the
file.

Choose Cancel to go back and select a different file name if you don’t want to
write over that file. Newton Connection exports the information to the
selected file. You can now work with your information in another application.
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Creating a user-defined template for information exchange
User-defined templates allow you to exchange information with a variety of
programs such as database, spreadsheet, and word-processing applications.
Templates define the name, order, and type of fields, as well as the delimiter
that separates fields and records. Templates can contain as many or as few
fields as necessary to accommodate your information.
Newton Connection supports the standard delimited file (SDF) format. SDF
is a loosely defined file format that many applications use as a means of
importing and exporting information. For example, suppose you have a
database that can write to the SDF format. When you want to use some of the
information stored in your database, you can save it to an SDF-formatted file.
Then, with Newton Connection, you can create a corresponding template, and
import that information into a workfile. If you import information into your
main workfile, the information is automatically transferred to your Newton
the next time you synchronize.
To create a template:
1

Choose Templates from the File menu.

The Templates dialog is displayed.
2

Choose a category to create a template for.
When you are done, click
here to close the dialog.

Click here to select
from the available
categories. You can
create templates for
only one category
at a time.

Click here to create a
new, empty template.
Use these buttons to work
with existing templates.

Existing templates are listed here.
Select a template to edit, copy, or delete it.
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3

Click New to display the New Template dialog.

4

Select the fields you want included in the template, then click Add.
Use these two buttons to add
or remove selected fields from
the Field Order list.

Click here to close the
dialog without saving your
changes to the template.

Select a field from this
list. Double-clicking
automatically copies
the field into the Field
Order list.

Use these two buttons to
change the position of a
field in the Field Order list.

64

Chapter 5

When you are done, click here
to close the dialog and save
your changes to the template.

Click here to display the
Advanced Template Options dialog.

If you want, you can change the way items are handled by modifying the
advanced options.
5

Click Advanced to display the Advanced Template Options dialog.
When you are done, click here to close the
dialog and save your changes to the template.

Click here to close the
dialog without saving your
changes to the template.

These options allow
you to choose which
characters separate the
fields and records.

Click here to include column
headings for fields in the file.

6

Choose OK to close the dialog and return to the New Template dialog.

7

Choose OK to save the template.

You can now use the template in place of the predefined application
translators when importing or exporting information. Instead of choosing a
predefined translation type from the Import or Export dialogs, you would
choose your own template from the Translation Type list.
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Troubleshooting information exchange
When using Import and Export, be aware of the following general guidelines:
m Depending upon the size limits of your application, you may not be able to
use or view all of your Newton Connection information. When opening the
exported file in another application, the Newton information may be
automatically truncated (for example, if the text fields are limited to a
particular length, you may lose part of the text from a longer entry).
m You may need to clean up the information once it has been translated to or
from the Newton’s file format.
m Verify the file format and other conventions of an application before
attempting to translate your information.
m Always keep a backup copy of your original information file.
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Appendix A
Using Commands

This appendix explains how to use the Newton Connection commands, select
items or text with either the keyboard or mouse, and move around in Newton
Connection. A complete summary of menus and commands is also included.

In this appendix
m Using menus, commands, and dialogs
m Moving around in Newton Connection
m Summary of menus and commands
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Using menus, commands, and dialogs
Much of what you do in Newton Connection is accomplished with
commands. Some commands take effect as soon as you choose them, while
others open a dialog box in which you supply additional information before
the command takes effect. When a command is followed by an ellipsis, a
dialog is displayed before the command is carried out.
Newton Connection commands appear on menus. The names of the menus
appear at the top of the window on the menu bar. You can access the
commands on a menu by using either the mouse or the keyboard. First you
open the menu, then you choose the command.
IMPORTANT Sometimes commands are only available under specific

circumstances. For example, you must have a workfile open before editing
commands—such as Cut, Copy, Paste, and Delete—become active.
Unavailable commands are dimmed. If you try to choose an inactive
command, the PC beeps.
It is recommended that you use a mouse with Newton Connection, but you
can access commands and use dialogs from the keyboard.

Using the keyboard
Windows has several ways to accomplish a task. It’s up to you to decide which
method is best for your style of working. If you prefer using the keyboard,
Newton Connection provides shortcuts and quick access to commands and
options with keystrokes and combinations.
Using the keyboard to choose menus and commands is accomplished with a
combination of keystrokes.
To choose a command:
1

Press Alt to activate the menu bar.

2

Press the key corresponding to the underlined character in a menu name to cause that
menu to drop down.

For example, to open the File menu, press Alt+F.
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3

Press the underlined character from the desired command name.

For example, to choose the Open command, press O.

Using shortcut keys
Some commands on menus have corresponding shortcut keys that activate
that command. The shortcut key combinations are listed on menus to the
right of the command name. Press the key combination to choose the
command directly. For example, to choose the Copy command you could
press Alt+E+C, or use the shortcut by pressing Ctrl+C. For a complete list of
Newton Connection shortcut keys, see “Summary of Menus and Commands”
later in this chapter.
The shortcut key is listed to
the right of the command.
When a command is
unavailable, it turns gray.

Selecting items
You can select one or more items from a list by using a combination of
navigation and command keys or by clicking with the mouse. If you want to
select a continuous group of items to print, for example, use the Shift key in
combination with the arrow keys.
To select an item or group of items:
1

Press Tab to move the focus to the items or group you want to work with.

2

With the arrow keys, move through the list or group to the item you want to select.

3

Press the Space bar to select the item. Or place the mouse cursor over the item and
click it once.

To select more than one item, press and hold the Shift key while moving
through the list with the arrow keys.
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Using dialog boxes
Dialog boxes request or supply additional information necessary to complete
a command. They also give you the opportunity to cancel an action. A dialog
box may contain text boxes, options, list boxes, and buttons. With some items
you can only choose one option, with others you can choose several options
from the same list.

Text boxes are one of
the options in a
dialog box.
A list box allows you
to select one of
several possible
settings.

A dialog box can also have
command buttons that
display other dialogs.
A checkbox allows
you to turn an option
on and off.

A checkmark means
that an option is on.

A text box is a field in which you type information needed to carry out a
command. The box may be blank or may contain default text when the dialog
box opens.
To type in a text box:
1

Click the box to place the insertion point, or press Tab to move to the box.

2

Type the necessary information.

If the box already has text in it, your typing replaces the existing text. If you
want to retain that text for editing, use the arrow keys to move the insertion
point before typing.
The insertion point
indicates that the text
box is ready to accept
your typing.
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In a dialog box, a list box contains a set of available choices. If all of the
choices do not fit in the box, there is a scroll bar which you can use to move
through the list. For example, in the Open dialog, a list box contains the files
in a given directory.
To select an item from a list box:
1

Click the scroll bar to display the item. Or press Tab until the box is active, then press
Down Arrow to open the list and move through it.

2

Click the item to highlight it. Or press the Space bar when the focus is on the item.

Double-clicking an item or pressing Enter completes the command.
Your selection is
shown here.

Click here to cause
the list to open.
Use the scroll bar to move
through the list of choices.

The current selection
is highlighted.

There are two types of options available—radio buttons and checkboxes.
Radio buttons are mutually exclusive; that is, you can only select one option
from the group. Checkboxes are independent. You can select several options
from the same group.
To choose an option:
m Click the item.
m Or press Tab until the group is active, use the arrow keys to move through
the list, then press the Space bar to turn the option on.
The option turns on or off each time you click it or press the Space bar.
This option allows you to
choose either view, but not
both. If you choose Close-Up,
then Summary is turned off.

When you select this
option, it enables the
fields below it.
You can have more than
one checkbox option
turned on at the same time.
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Moving around in Newton Connection
The following table summarizes keys that you can use to move around in
most menus, dialog boxes, and windows.
Summary of navigation keys
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To…

Press…

Open a menu

Alt+letter

Move through a list

Arrow keys

Delete text to left of cursor

Backspace

Activate a shortcut key

Ctrl+letter

Insert a tab in a text box

Ctrl+Space

Move between windows

Ctrl+Tab

Delete the selection or text to right of cursor

Del

Move to end of the text

End

Add a new paragraph, or
close a dialog and complete the command

Enter

Close a dialog without completing
the command

Esc

Move to the beginning of the text

Home

Move one screen down in the display

Page Down

Move one screen up in the display

Page Up

Move to the previous option

Shift+Tab

Select the current item

Space bar

Move to the next option

Tab

Summary of menus and commands
The following table summarizes the Newton Connection menus and
commands.
Newton Connection menus and commands
Command

Shortcut

Description

File menu
New

Create a new workfile. Newton Connection prompts you
to name the file, then displays an empty file for use.

Open

Select a workfile for editing and display it in the current view.
You can open more than one file at a time.

Close

Close the current workfile window. This command does not
exit Newton Connection.

Import

Merge the information from the selected file into the current
workfile.

Export

Copy your Newton information to the selected file in
order to use it in another application.

Export Selected

Copy the selected items from the current category to a
file in order to use it in another application.

Templates

Create or modify a template to use when importing or
exporting information for use with another application.

Print

Ctrl+P

Print Setup
Exit

Print the current category in the current view.
Specify a printer and setup options.

Alt+F4

Quit Newton Connection and close all active workfiles.
continues .
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Command

Shortcut

Description

Undo

Ctrl+Z

Reverse the last editing operation.

Cut

Ctrl+X

Remove the selection and place it on the clipboard.

Copy

Ctrl+C

Place the selection on the clipboard without removing it from
the file.

Paste

Ctrl+V

Insert the clipboard contents at the insertion point.

Delete

Del

Remove the selection without placing it on the clipboard.

Edit menu

Select All
New Item

Select all items in the current view, or select all text in the
current field.
Ins

Add a new, empty item to the current category.

Enter

Display all details of a single item for viewing or editing.

View menu
Zoom
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Notepad

Display your notes in the order you entered them.

Name File

Display names, telephone numbers, addresses, and other
important information in a card format.

Calendar
`

Display your appointments and day notes, sorted by
date and time.

To Do

Display your daily tasks, sorted by date and priority.

Extras

Display information for any packages you may have installed
on your Newton.

Field Display

Specify which fields are displayed in the summary view.

Search

Specify the criteria by which to limit the items available
for viewing and editing in Notepad or Name File.

Sort by

Specify which field you want the summary view sorted by.

Ascending/Descending

Specify whether the summary view is sorted in ascending or
descending order, according to the contents of the field you
are sorting by.

Dates Navigator

Display the Dates Navigator for moving around in Calendar
and To Do.

Command

Shortcut

Description

Newton menu
Restore*

Copy items from the backup file to your Newton
and workfile.

Install Package

Add additional functionality to the Newton. These packages
are purchased separately.

Preferences

Specify how Newton Connection transfers information
and control the parameters for serial port settings. These
preferences are stored in the NEWTON.CFG file.

Communications On

Control communication with all enabled serial ports. When
checked, communications are on; when not checked, you are
unable to synchronize.

Window menu
Tile

Rearrange the opened files so that all windows are visible.

Cascade

Cause the windows to overlap so that each title bar is visible.

Arrange Icons

Rearrange the Newton Connection file icons evenly across
the bottom of the main workspace.

Files List

A list of currently opened workfiles. If you choose one of the
file names from the list, it becomes the active window.

Help menu
Contents

Display the Help Contents to select a topic for viewing.

Index

Display the Help Index to search for a topic to view.

Procedures

Display a list of How To procedures to choose from.

About Newton
Connection

Display the version, copyright, and registration information for
Newton Connection.

*This command will erase your existing information. Use with caution.
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Appendix B
System Information

This appendix contains information concerning your PC’s system
requirements. It also details how the Install program modifies your Windows
system files.

System requirements
To use Newton Connection and communicate with the Newton, your PC must
meet the following minimum requirements:
m 100% IBM PC compatible
m Intel 80386 or better
m VGA display or better
m Hard disk with at least 5 MB free space
m Serial port
m 5 MB RAM
m MS DOS 3.1 or higher
m Windows 3.1, Enhanced Mode
A mouse or other pointing device is recommended.
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Modifying Windows system files
The Install program automatically modifies WIN.INI and SYSTEM.INI, and
optionally modifies PROGMAN.INI, as noted below. Install also creates a
file, CHANGES.TXT, that details the changes made to these system files. It
can be found in the Newton directory or on your installation disk.
m SYSTEM.INI

[386Enh]
DEVICE=C:\NEWTON\TSIVID.386
m WIN.INI

[Extensions]
nwt=C:\NEWTON\NEWTON.EXE ^.NWT
m PROGMAN.INI

[Groups]
GROUP#=C:\WINDOWS\NEWTON.GRP
where # equals an available group number.
If you instruct the Install program not to create a group for Newton
Connection, you can do so at a later time. For information on how to create a
group or add a program icon to a group, see the Windows User’s Guide.

78

Appendix B

Glossary

A
Appointment An item in the Calendar. See also Calendar; Dates Navigator.
Archive file A Newton Connection file on the PC that receives synchronized
data that was later deleted from Newton. Compare to Backup file.

B
Backup file A copy of the user’s workfile automatically created by Newton
Connection. You can create up to 10 backup files. The Restore command
replaces all data on Newton with the data from a specified backup file or
workfile. See also Restore. Compare to Archive file.
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C
Calendar A Newton Connection category containing appointments and day
notes for each day. You move through the Calendar by choosing a specific day
from the Dates Navigator. See also Appointment; Dates Navigator; Day notes;
To Do.
Category A type of information. The four predefined categories in Newton
Connection are Name File, Calendar, To Do, and Notepad.
Clipboard A temporary storage location used to transfer records or text
between categories or between Newton Connection and other Windows
applications. Information is transferred to the clipboard with the Cut and
Copy commands. You can then insert the information at a new location with
the Paste command.
Close-up view The information for a single item is displayed in a separate
window. You can add new information or edit existing items in this view. The
type and number of fields depend on the current category. Compare to
Summary view.
COM port See Serial port.

D, E
Dates Navigator A mini-calendar used to move from one day to the next
when viewing your appointments or to-do items. See also Calendar; To Do.
Day notes Textual reminders from each day stored with your appointments.
A day note doesn’t have a specific time associated with it. See also Calendar;
To Do.

F, G, H, I, J, K, L
Focus The location or item to receive the next keyboard action or command.
When an item or window is active, it has the focus.
Folder A field designating which folder the item is stored in on Newton.
Both Notepad and Name File items can be stored in folders.
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M
Menu bar The horizontal bar at the top of the main workspace, containing
the menus available in Newton Connection. See also Toolbar.

N, O
Name File A Newton Connection category containing a list of your contacts,
their phone numbers, addresses, and other pertinent information.
Notepad A Newton Connection category containing notes, graphics, and
general information.

P, Q
Package A collection of forms, fonts, system updates, or applications that
can be directly loaded onto Newton via Newton Connection. Packages are
purchased separately.

R
Restore Replaces the items in the Newton device and its associated workfile
with the contents of a user-specified backup file. Compare to Synchronize.

S
Search Retrieves items from a category based on user-defined criteria and
displays the items for viewing.
Selection The highlighted item, text, or other information that describes
what will be acted upon by the next command or keyboard action.
Serial port A port on your computer for communicating via cable. Serial
ports on PCs have visible pins and come in two sizes—DB9 and DB25. A
serial port may be labeled COM1, COM2, COM3, or SERIAL.
Status bar An area at the bottom of the Newton Connection workspace
containing hints or a brief description about the currently highlighted
command or toolbar button.
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Summary view A listing of items in a single category. Each item is listed on a
single line. You can scroll through the list, select one or more items, and print
items from summary view. Compare to Close-up view.
Synchronization The process by which Newton Connection ensures that the
information on the Newton and in your workfile are identical. Compare to
Restore.

T, U, V
Toolbar The horizontal bar just below the menu bar, containing command
buttons. Choosing a button from the toolbar is the same as choosing the
equivalent command from a menu. See also Menu bar.
To Do A Newton Connection category containing a list of tasks and other
things you need to complete. You can assign priorities to your tasks. They are
sorted based on the date you entered them. See also Calendar; Dates
Navigator; Day notes.

W, X, Y, Z
Workfile A file on the PC that is the main data file. When you synchronize,
an automatic exchange of information occurs between the Newton and its
workfile.
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Index

A
About Newton Connection command 75
address, editing 45
All option 41
application window 8–9
appointment, defined 30, 79
archive
deleted items 4
must synchronize first 49
items 49–50
archive file
creating a new 17
defined 79
retrieving items from 49
warning for restore 48
Arrange Icons command 75
Ascending/Descending button 39
Ascending/Descending command 74
Automatically open workfile option 44

B
backing up workfiles 23
backup file
defined 79
restoring from 47–48

specifying how many 44
Backup Files option 23, 44
baud rate, changing 45, 56
Browse button 6
Browse command button 44

C
cable, connecting 2
Calendar
defined 29, 80
navigating in 31
notes, text only 33
sort order for 30
Calendar command 74
Cascade command 75
category, defined 28–29, 80
category buttons, defined 29
CHANGES.TXT 78
checkboxes, using 70, 71
clipboard
defined 80
using 34, 50, 73
Close command 73
Close-up option 42
close-up view, defined 31, 80
closing workfiles 11
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COM port. See serial port
command button, defined 70
command buttons, toolbar 8, 28
commands
defined 73–75
dialog boxes 70
using 68–69
with ellipsis 9
communications, disabling 46–47
Communications On command 47, 75
Connect button 3, 18, 25
connecting, serial cable 15
Connection button 3, 17, 47
Connection icon 18, 48, 51
Contents command 75
Copy command 74
creating workfiles 19
Cut command 36, 50, 74

D
data directory, specifying 44
Dates Navigator
defined 80
using 31
Dates Navigator command 74
Dates option 42
day notes, defined 30, 80
DB9–DB25 adapter 5, 15
Defaults button 45
Delete command 36, 74
deleting items 4
dialog box
defined 70
using 70–71
DOS or Windows PC option 3, 18,
48, 51
drop–down list
defined 70
using 71

E
editing
notes 33–34
reversing 36
Edit menu, summary 73
Enabled option 45, 46, 54
exchanging information
described 58
exporting 60–61
exporting selected items 62
importing 59–60
templates 63–65
Exit command 11, 73
Export command 60, 61, 73
Export Selected command 62, 73
Extra Large Memory option 44, 55
Extras command 52–53, 74
Extras drawer 3, 18, 25, 48, 51

F
F1 key 10
Field Display command 40, 74
File Manager 7
File menu, summary 73
Filename field 20
Files, opening after synchronize 44
Files list 75
folder
defined 80
using 42

G
graphics, view only 33, 34
group, creating 2, 78

H
Help, online 10
Help menu, summary 75
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Index

I, J

K

ID code for Newton 7
Import command 59, 60, 73
Index command 75
information
controlling display of 37–40
editing items 32–36
managing 13–14
moving 35
printing 40–42
removing 36
restoring 47–48
saving 21–22
sharing 24
tips 24–25, 42
viewing 30–31
Install
modifying system files 78
program 2, 5, 78
INSTALL.EXE 2, 5
installing
Newton Connection 2, 5–6
packages 51–52
Install Package command 51, 75
Install Package dialog 51
interface, described 8–9
item
adding 32
archiving from Newton 36, 49–50
creating 32, 74
editing 30, 32–36
hiding 37
moving 35
printing 41–42
removing 36, 49
restoring 36
saving, automatic 21
selecting 69, 73
viewing 30–31
itinerary, creating 42

keyboard, using 5, 68

L
list box, using 71

M
mailing list, creating a customized 42
memory
increased 44
low in Windows 56
menu, opening 68
menu bar
defined 9, 81
using 68–69
modem, conflicts with Newton
Connection 54
mouse, recommended 5, 68

N
Name File
defined 29, 81
searching 74
sort order 35
Name File command 74
Name File dialog 34
.NAR 28, 49
navigation keys, summary 72
.NB# 23, 28
New command 19–20, 73
New Item button 32
New Item command 32, 74
Newton
group 6
ID code 7
restoring information to 47–48
synchronizing with 16–19
writing over information on 48
NEWTON.CFG 44, 74

Index
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Newton Connection
application window 8–9
attaching the cable 2
baud rate for 3
customizing 44–47
default settings 43–45
Help for 10
icon 2, 6, 7, 25
installing 2, 5–6
quick start 2–3
quitting 11
restoring defaults 45
saving, automatic 11
screen 8–9
starting 3, 7
what is 4
Newton menu, summary 74
Notepad
defined 28, 81
searching 37, 74
sort order 35
using 34
Notepad command 74
Notepad dialog 34
notes, editing 33–34
.NWT 7, 20, 28, 49

O
Open command 20, 73
options, choosing 71

P
package, contents 5
packages
defined 81
installing 43, 51
viewing 52–53
Paintbrush 33
Paste command 22, 34, 74
port contention, Windows 55

86

Index

port setup
advanced troubleshooting 56
changing 44, 45–47
Port Setup button 54
Port Setup dialog 45, 46
preferences
customizing 44–47
port setup 45–47, 54
Preferences command 23, 75
Preferences dialog 23, 44, 46
Print command 73
Print dialog 42
printer, choosing 41
printing
information 41, 73
selected items 41–42
Print Manager 40
Print command 73
Print Setup command 73
Procedures command 75
PROGMAN.INI 5, 78
Program Manager 2, 5–6, 7, 25
PS/2, serial port setting for 56

Q
Quick Start 2–3
quitting
automatic save 11, 32
Newton Connection 11

R
radio buttons 71
radio interference, warning vi
repeating appointments, read–only 33
requirements, system 5, 77
restore
backup files 47–48
defined 81
Restore command 47, 75
Restore dialog 48
Run command 5

S
saving
automatic 11, 32
information 21–22
search, defined 81
Search command 37–38, 74
searching
canceling 38
items 37–38
Select All command 74
selecting
items 69
text 70
selection, defined 81
Selection option 41
serial cable
attaching 15–16
using with Newton 54
serial port
address 45, 56
contentions 45
defined 15, 81
disabling 54
turning on 74
using an adapter with 5, 15
shortcut keys, using 69
Show Toolbar option 44
Sort By command 39, 74
sorting
Ascending/Descending order 39, 74
defined 38-39
starting Newton Connection 3,7
status bar, defined 8, 81
summary
commands 73–75
field display, changing 39–40
navigation keys 72
toolbar buttons 9
Summary option 41
summary view, defined 30, 82
synchronize
background 4, 25

canceling 19
defined 82
first time 3, 16–17
information management 17–19
instructions for 7, 17
not able to 54, 74
with Newton 16–19
system
information 77–78
requirements 77
system files
changing 2
Windows 78
SYSTEM.INI 5, 78

T
tab
typing in a text box 72
using in a dialog box 32
television interference, warning vi
Templates command 63–65, 73
text box, using 70
Tile command
defined 75
using 22
tips
managing information 24–25
using information 42
To Do
defined 29, 82
navigating in 31
notes, text only 33
To Do command 74
toolbar
defined 9, 82
hiding 44
troubleshooting
advanced port setup issues 56
common problems 54
modem conflicts 54

Index
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View menu
defined 28
summary 74
viewing, information 30–31

workfile
backing up 23
closing 73
creating 19–20, 73
currently open 75
defined 14, 82
multiple 4
must synchronize to create 7
name 3
opening 20–21
using 14

W, X, Y

Z

WIN.INI 5, 78
window
activating 35
application 8–9
moving between two 20
viewing two side–by–side 75
Window menu, summary 75
Windows
clipboard 34, 50
creating a group in 78
Enhanced mode 77
File Manager 7
keyboard vs. mouse 68
low-memory messages 55
Paintbrush 33
port contention messages 55
Program Manager 2, 5–6, 7, 25
restart 6
starting 2
system files, modified 78
using other applications with Newton
Connection 46

Zoom command 31, 32, 33, 74

U
Undo command 36, 74
user preferences 44–46

V
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